How do I get rid of a stuck train?

lemontwist
  • How do I get rid of a stuck train? lemontwist

    I have an old electric train that's been stuck for quite a while. During upgrading I upgraded the electric rail station to maglev while a train was in the depot. However, the train was never "stopped" in the depot. I switched the station back to electric -- but the train is still stuck in a netherland between the depot and the station. It won't go to the station, and it won't go back into the depot either. Here's a screen shot to give you an idea of how it looks.

    I have no idea how to delete it. It loses me a decent sum each year. What can I do?

  • Build another depot somewhere and connect it with that track, build the cheapest train you can find, manage to crash it with the other train. In a while both trains will disappear.

    Cons are that you'll instantly lose reputation in your station, but as time passes, you'll get it back to normal.

Tags
openttd
Related questions and answers
  • How do you make a tunnel in A train 8. I have got the tunnels lined up and at the same elevation but the train refuses to go through.

  • I have recently installed the traincarts plugin on my server. So far I have been getting along fine, until the part about destinations and path-finding. What I want to know is how do I set/name a station so that the train knows where its going. I have a station and a train called train2, I want it to be able to get to the second station without losing its way. If you would find it easier to demonstrate this please say and I could whitelist you on my server. Thanks.

  • I currently have an intersection of trains. 4 go parallel and 1 perpendicular. I would like to let the 4 parallel trains all go if they approach the intersection at the same time. However, they all stop until one train gets through. I have to admit I'm not so great at signals, so I'm sure I'm doing something wrong. Here's the layout:

  • I have a space station on Duna orbit, equipped with Mobile Processing Lab MPL-LG-2. I plan to decommission it and bring my kerbals back (or move them to the new station). But I have no idea how to make them go EVA. Only pilots are listed in the right down corner of my screen (one for station, 2 for rescue vehicles). Is there any way to do it, without hacking saves or using Crew Manifest?

  • I am playing Pokemon Crystal on an emulator (visual boy advance). I've made it to the Kanto region and got as far as Cerulean City and got stuck at the gym. I went to the power plant and normally the manager says the generator is missing a part. In my game the manager say it's running fine and gives me a TM. I go back to the Cerulean Gym and there is no Team Rocket member waiting for me... needs her pokedoll from Vermillion City isn't even asking for it and gave me the "Pass" for the magnet train right away Although I have the pass and the power plant has the power working the train

  • and starting over, creating a closer depot for them to go to, etc. None of these actions have helped. I was hoping that this rig would eventually disappear form lack of activity, but it still registers a ~20% transport rate for both oil and passengers, so I doubt it's going to go away. ...I have a boat that goes between an oil rig (Dreningbury Valley) & a dock, I also have a hover boat that goes between multiple oil rigs. For some reason both of these boats got stuck at a single

  • I have a train track loop on a map with two trains on it. Orders for both trains are identical, and they move clockwise around the loop: station A -> waypoint A -> station B -> waypoint B -> ... However one of the two trains is always parked at the depot. When the currently active train enters the depot for maintenance the other takes off. What changes do I need to make such that I can have more than one train operating on the loop simultaneously?

  • I've been playing team RUA2 just fine for a while, but suddenly the game is telling me that I'm offline. How do I get it to go back online and avoid having it go "offline" again?

  • While recently playing a game of Civilization 5 (with Gods & Kings) I seem to have run across a bug with the cultural borders. In the image below the city of Budapest is surrounded by the borders of the Ethiopian empire, which no longer exists. Originally Budapest was a city-state that was conquered by Rome. Ethiopian and myself went to war with Rome shortly after, and while I took out the Roman cities Ethiopia went and took Budapest. Eventually I conquered the Ethiopians, but for some reason the Ethiopian border continues to persist around Budapest. Any idea how I may fix

Data information